وَمَا هَٰذِهِ ٱلْحَيَوٰةُ ٱلدُّنْيَآ إِلَّا لَهْوٌ وَلَعِبٌ ۚ وَإِنَّ ٱلدَّارَ ٱلْءَاخِرَةَ لَهِىَ ٱلْحَيَوَانُ ۚ لَوْ كَانُوا۟ يَعْلَمُونَ

“Dan tiadalah kehidupan dunia ini melainkan senda gurau dan main-main. Dan sesungguhnya akhirat itulah yang sebenarnya kehidupan, kalau mereka mengetahui.” (QS. Al-Ankabut:64)

Thursday, 26 November 2020

Administrasi Jaringan: Pertemuan 11-Network Address Translation (NAT)

Kemampuan Akhir Yang Direncanakan: Mahasiswa mampu memahami dan menjelaskan cara kerja NAT
 

Bahan Kajian (Materi Pembelajaran): Network Address Translation
1. Definisi
2. IP Address Private
3. Jenis-jenis NAT
4. Keamanan
5. Firewall NAT
6. Konfigurasi Static NAT
7. Konfigurasi Dynamic NAT

Definisi
Network Address Translation (NAT) dapat didefinisikan sebagai penerjemah alamat IP Address lokal agar dapat terkoneksi kedalam alamat IP public

NAT merupakan salah satu protocol dalam suatu sistem jaringan, NAT memungkinkan suatu jaringan yang belum teregistrasi di jaringan internet untuk mengakses jalur internet
NAT biasanya dibenamkan dalam sebuah router, NAT juga sering digunakan untuk menghubungkan dua jaringan yang berbeda, dan menerjemahkan IP Privat ke dalam IP Public

IP Address Private
IP Address private tidak dapat di route ke dalam jaringan internet (non-routed), hanya dapat digunakan pada jaringan internal saja. Berikut range dari IP Address Private


Jenis-jenis NAT
NAT merupakan perpindahan suatu alamat IP ke alamat IP lain.
Ada dua macam dari NAT, yaitu:

  1. DNAT (Destination Network Address Translation) Digunakan untuk meneruskan paket dari IP Public melalui firewall ke dalam suatu Host
  2. SNAT (Source Network Address Translation) Dipergunakan untuk merubah source address dari suatu paket data. Sebagai contoh penggunaannya pada Gateway Internet.

Keuntungan dan Kekurangan Keuntungan NAT

  • Menghemat skala pengalamatan IP Address yang terdaftar
  • Meningkatkan fleksibilitas koneksi ke jaringan public
  • Menyediakan konsistensi untuk jaringan
  • Menyediakan keamanan jaringan


Kekurangan NAT

  • Kinerja jaringan menjadi terdegradasi 

Keamanan

  • Ketika komputer terkoneksi kedalam jaringan internet, komputer tersebut tidak saja dapat mengakses ke Server tertentu. Akan tetapi komputer tersebut juga dapat diakses oleh komputer lain yang terkoneksi ke dalam jaringan internet.
  • NAT akan bertanggung jawab secara otomatis untuk mengizinkan dan mengamankan jaringan dengan menggunakan Firewall.

Tipe NAT
1. Static NAT
Menggunakan pemetaan satu arah untuk menghubungkan alamat IP Lokal dengan alamat IP Public. NAT static sangat berguna untuk server web dikarenakan lebih konsisten

2.Dynamic NAT
Menggunakan sekumpulan alamat IP Public dan memberikan layanan terhadap yang pertama kali datang atau pertama kali akses kedalam NAT

Tipe NAT
Port Address Translation (PAT)

Merupakan fitur dari sebuah jaringan yang menerjemahkan alamat TCP atau UDP. Sebagai contoh, port 80 terhubung ke Web Server dan port 25 untuk Mail Server.

Firewall NAT
NAT mampu mengimplementasikan secara penuh keamanan filtering dengan menjaga security, yang digunakan untuk menjaga data flow dari dan yang menuju ke network anda

Konfigurasi Static NAT

Langkah 1: Melakukan konfigurasi alamat inside local ke alamat inside global

Router(config)#ip nat inside source static local-ip global-ip

Langkah 2: Spesifikasi inside interface

Router(config)#interface type number

Router(config-if)#ip nat inside

Langkah 3: Spesifikasi outside interface

Router(config)#interface type number

Router(config-if)#ip nat outside 

R2(config)#ip nat inside source static 192.168.10.254 209.165.200.254
R2(config)#interface serial0/0/0
R2(config-if)#ip nat inside
R2(config-if)#interface serial 0/1/0
R2(config-if)#ip nat outside

Konfigurasi Dynamic NAT

Langkah 1:  Definisikan alokasi alamat yang digunakan
Router(config)#ip nat pool name start-ip end-ip {netmask netmask|prefix-length prefix-length}
Langkah 2:  Definisikan standar access list
Router(config)#access-list access-list-number source source-wildcard
Langkah 3:  Masukan kelompok alamat IP kedalam access list
Router(config)#ip nat inside source list access-list-number pool name
Langkah 4:  Spesifikasikan inside dan outside interface
Router(config)#interface type number
Router(config-if)#ip nat inside
Router(config-if)#ip nat inside
R2(config)#ip nat pool NAT-POOL1 209.165.200.226 209.165.200.240 netmask 255.255.255.224
R2(config)#access-list 1 permit 192.168.0.0 0.0.255.255
R2(config)#ip nat inside source list 1 pool NAT-POOL1
R2(config)#interface serial 0/0/0
R2(config-if)#ip nat inside
R2(config-if)#interface serial s0/1/0
R2(config-if)#ip nat outside

 ======Terima kasih========

Tuesday, 24 November 2020

Video Pembelajaran Praktikum Jaringan Komputer Pertemuan 12: Konfigurasi Dynamic Routing (OSPF) Mikrotik di VirtualBox

  • Kemampuan Akhir Yang Direncanakan:Mahasiswa dapat membuat konfigurasikan routing dynamic.
  • Bahan Kajian (Materi Pembelajaran): Routing EIGRP dan OSPF

 

======= Selamat Mengerjakan ========

Thursday, 19 November 2020

Administrasi Jaringan: Pertemuan 10- Praktikum Routing


Kemampuan Akhir Yang Direncanakan:
Mahasiswa mampu memahami konsep routing dan mampu mengimplementasika n Routing Dynamic EIGRP, OSPF dan Mahasiswa mampu memahami tentang konsep dari Multiarea OSPF

Bahan Kajian (Materi Pembelajaran:

Routing Dynamic
1. Protokol Routing Dinamis
2. EIGRP
3. EIGRP IPv6
4. OSPF
5. OSPFv3
6. Single Area OSPFv3
7. Multiarea OSPF

Studi Kasus - Tugas Individual
Perusahaan XYZ memiliki 3 kantor Cabang. Pada kantor cabang 1 memiliki 14 komputer yang terhubung menggunakan kabel serta terdapat 5 Laptop yang terhubung menggunakan media Wireless. Sedangkan pada kantor cabang 2, memiliki 20 komputer yang terhubung menggunakan kabel. Dan kantor cabang 3 memiliki 10 komputer.

Anda sebagai seorang Network Administrator diminta untuk melakukan konfigurasi terhadap ketiga kantor cabang tersebut dengan ketentuan, sebagai berikut:
  1. Melakukan konfiguarsi IP Address dengan menggunakan Subnetting pada perangkat Komputer dan Laptop yang terhubung. Tidak dianjurkan menggunakan /24,
  2. Berikan IP Address dengan menggunakan subnetting /30 terhadap interface yang terhubung secara langsung dari router ke router,
  3. Terapkan konfigurasi Routing Dynamic,
  4. Serta pastikan seluruh Client di Kantor Cabang 1, kantor cabang 2 dan kantor cabang 3 dapat saling terkoneksi dengan baik
  5. Setelah jaringan berjalan sesuai dengan fungsinya, upload dokumentasi pembuatan jaringan kedalam blog

--------------Selamat Mengerjakan------------

Tuesday, 17 November 2020

Video Pembelajaran Praktikum Jaringan Komputer Pertemuan 10 & 11

(Kemampuan Akhir Yang Direncanakan):Mahasiwa dapat memahami konsep Tunnel dan mampu menerapkan Tunnel pada system jaringan Bahan Kajian (Materi Pembelajaran):Tunnel Overview, PpoE, PPTP, EoIP, L2TP

Konfigurasi VPN Mikrotik Dengan Metode PPTP Di VirtualBox

 

------------Selamat Mengerjakan-------

Thursday, 12 November 2020

Administrasi Jaringan: Pertemuan 9-Routing Dynamic EIGRP dan OSPF

  • Kemampuan Akhir Yang Direncanakan: Mahasiswa mampu memahami konsep routing dan mampu mengimplementasikan Routing Dynamic EIGRP, OSPF dan Mahasiswa mampu memahami tentang konsep dari Multiarea OSPF

  • Bahan Kajian (Materi Pembelajaran): 
 
Routing Dynamic
1. Protokol Routing Dinamis
2. EIGRP
3. EIGRP IPv6
4. OSPF
5. OSPFv3
6. Single Area OSPFv3
7. Multiarea OSPF
Protokol Routing Dinamis
Tujuan Protokol Routing Dinamis:
  • Up-to-date informasi routing
  • Memilih jalan terbaik pada jaringan
Jenis Routing Protokol:
  • Link-State
  • Distance Vector
  • Path-Vector

 Konsep
  • Router mengirim dan menerima pesan routing pada interface,
  • Router bertukar informasi untuk mempelajari routing yang digunakan,
  • Ketika router mendeteksi adanya perubahan topologi, protokol routing akan memperbaharui 

EIGRP memiliki beberapa fitur yang tidak dimiliki oleh distance vector routing protocol lainnya, seperti:
  • Reliable Transport Protocol (RTP)
  • Bounded updates / Pembaruan yang tidak direncanakan
  • Diffusing Update Algorithm (DUAL)
  • Establishing adjacencies
  • Neighbor and Topology Tableinformasinya. 
Fitur EIGRP
Reliable Transport Protocol
  • Digunakan untuk pengiriman dan penerimaan paket EIGRP,
  • Dapat mengirim paket menggunakan IPv4 dan IPv6.

Diffusing Update Algorithm (DUAL)
  • Merupakan algoritma yang digunakan untuk mencegah looping pada routing,
  • Tidak berpengaruh walaupun terjadi perubahan topologi,
  • Serta menyediakan waktukonvergensi yang lebih cepat
Konfigurasi EIGRP IPv4 
Autonomous System Number
1.IANA Global
  • Digunakan oleh ISP dan lembaga-lembaga besar lainnya
  • Digunakan pada Routing Exterior, seperti BGP
2.Router eigrp autonomous-system
  • Nomor Autonomous-system digunakan sebagai ID,
  • Semua router didalam domain yang sama harus menggunakan Nomor Autonomous-system yang sama.
 
Konfigurasi EIGRP IPv6
EIGRP IPv6
  • Memiliki fungsi yang sama seperti EIGRP IPv4
  • Menggunakan IPv6 untuk melakukan komunikasi dengan EIGRP
  • Proses EIGRP IPv6 terpisah dengan EIGRP IPv4
  • Menggunakan alamat Link-local FE80::/10
Proses Konfigurasi EIGRP IPv6
  • Menggunakan ipv6 unicast routing untuk mengaktifkan routing IPv6
  • Menggunakan ipv6 route eigrp autonomous-system untuk masuk kedalam mode konfigurasi. Dan harus menggunakan perintah no shutdown untuk mengaktifkannya.
OSPF (Open Shortest Path First)
OSPF merupakan protokol routing link state dan digunakan untuk menghubungkan router-router yang berada dalam satu Autonomous System (AS) sehingga protokol routing ini termasuk juga kedalam kategori Interior Gateway Protocol (IGP).
 
Kelebihan dan Kekurangan OSPF
Kelebihan dari OSPF:
  • Tidak menghasilkan routing loop
  • Mendukung penggunaan beberapa metrik sekaligus
  • Dapat menghasilkan banyak jalur ke sebuah tujuan
  • Membagi jaringan yang besar menjadi beberapa area
  • Waktu yang diperlukan untuk konvergen lebih cepat
Kekurangan dari OSPF:
  • Membutuhkan basis data yang besar
  • Lebih rumit
Karakteristik OSPF
  • Merupakan link state routing protocol, sehingga setiap router memiliki gambaran topologi jaringan.
  • Menggunakan Hello Packer untuk mengetahui keberadaan router tetangga (neighbor router).
  • Routing update hanya dikirimkan bila terjadi perubahan dalam jaringan dan dikirim secara multicast.
  • Dapat bekerja dengan konsep hirarki karena dapat dibagi berdasarkan konsep area.
 
OSPF terdiri dari 2 versi:
  • OSPFv2 untuk IPv4
  • OSPFv3 untuk IPv6
Implemantasi OSPF:
  • Single-area OSPF
  • Multi-area OSPF
 
OSPF Router ID
Mengaktifkan OSPFv2
  • OSPFv2 diaktifkan menggunakan perintah router ospf process-id
  • Process-id merupakan angka antara 1 sampai 65.53

Konfigurasi OSPFv2

 

R2(config)#router ospf 10
R2(config-router)#router-id 1.1.1.1
R2(config-router)#network 10.1.12.0 0.0.0.255 area 0
R2(config-router)#network 10.1.23.0 0.0.0.255 area 0
R2(config-router)#passive-int g0/0

Single-Area OSPFv3

  • OSPFv3 mirip seperti OSPV2, namun pertukaran informasi routing menggunakan tabel routing IPv6
  • Menggunakan alamat Link-local, alamat ini secara otomatis akan terbentuk ketika IPv6 unicast global digunakan pada interface

 

 Untuk mengaktifkan OSPFv3 pada semua interface, dapat menggunakan perintah ipv6 ospf process-id area area-id.

Multiarea OSPF

OSPF dibuat dan dirancang untuk melayani jaringan lokal berskala besar. Semakin membesarnya area
jaringan yang dilayaninya akan semakin banyak informasi yang saling dipertukarkan.

Ketika sebuah jaringan semakin membesar, routing protokol OSPF tidak efektif lagi jika dijalankan dengan hanya menggunakan satu area saja. Seperti yang telah Anda ketahui, OSPF merupakan routing protokol berjenis Link State.

Ciri-ciri dari routing Multiarea OSPF ini adalah menggunakan beberapa area atau minimal 2 area dalam implementasinya

Alasan Menggunakan Multiarea
Single Area OSPF

  • Jika routing tidak diringkas, maka tabel routing dapat menjadi sangat besar
  • Setiap router harus menjaga informasi tentang domain routing yang digunakan 

Multiarea OSPF

  • Memiliki tabel routing yang lebih kecil
  • Mengurangi link-state
OSPF Two-Layer pada Area Hierarchy
  • Backbone (Transit)
  • dan Regular (Non-backbone)
 

Type OSPF

  • Backbone Routers
  • Internal Routers
  • ABR – Area Border Routers
  • ASBR – Autonomous System Boundary Routers
 

Konfigurasi Multiarea OSPF
Menerapkan Multiarea OSPF
  • Jenis implemetasi OSPF dipilih berdasarkan pada persyaratan desain jaringan dan topologi yang digunakan.

 

Verifikasi Multiarea OSPFv2

  • Perintah yang digunakan untuk melakukan verifikasi singlearea OSPF sama dengan perintah yang digunakan untuk multiarea OSPF.
  • Untuk OSPFv3, hanya mengganti “ip” dengan “ipv6”.
Verifikasi Rute OSPFv2 
  • Perintah yang paling umum digunakan untuk melakukan verifikasi multiarea menggunakan perintah “show ip route”.

Konfigurasi Multiarea OSPF
Contoh


Pada skema jaringan diatas:
R1 menggunakan Area 0 dan Area 1, R2 menggunakan Area 0, sedangkan R3 menggunakan Area 0 dan Area 2.


R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 10.1.1.0 0.0.0.255 area 1
R1(config-router)#network 10.1.2.0 0.0.0.255 area 1
R1(config-router)#network 192.168.10.0 0.0.0.3 area 0


R2(config)# router ospf 1
R2(config-router)# router-id 2.2.2.2
R2(config-router)# network 10.2.1.0 0.0.0.255 area 0
R2(config-router)# network 192.168.10.0 0.0.0.3 area 0
R2(config-router)# network 192.168.10.4 0.0.0.3 area 0
 
 
R3(config)# router ospf 1
R3(config-router)# router-id 3.3.3.3
R3(config-router)# network 192.168.2.0 0.0.0.255 area 2
R3(config-router)# network 192.168.1.0 0.0.0.255 area 2
R3(config-router)# network 192.168.10.4 0.0.0.3 area 0
=======================================
 
 DISKUSI
Konfigurasi EIGRP IPv4
 
 
 
 
 
 
 
 
 











































































































































































































































Tuesday, 10 November 2020

Praktek Jaringan Komputer: Pertemuan 9 - Konfigurasi Static Routing Mikrotik Di VirtualBox

  • Kemampuan Akhir Yang Direncanakan:Mahasiswa dapat memahami konsep routing dan mampu menerapkan system Routing pada Router
  • Bahan Kajian (Materi Pembelajaran):Routing Static

 

---------Selamat Mengerjakan------

Tuesday, 27 October 2020

Praktikum Jaringan Komputer: Pertemuan 6 & 7- Concept Bridging

(Kemampuan Akhir Yang Direncanakan)

  • Mahasiswa dapat memahami dan menerapkan konsep Bridging pada sebuah router OS


Bahan Kajian (Materi Pembelajaran)

  • Bridging Concept Bridging

Video Pembelajaran Praktikum Jaringan Komputer Pertemuan 6

 

 Konfigurasi Bridging Mikrotik di Virtual Box

  

------------Selamat Mengerjakan---------